Welcome Guest Search | Active Topics | Log In | Register

Can't connect local or direct WiFi Options
Charlie Dude
#1 Posted : 04 November 2019 16:24:01

Rank: Beginner Level 3

Groups: Registered

Joined: 04/09/2019
Posts: 28
Points: 84
Location: Kent, Wa.
I finished my R2 and when powered up all went well with no problems. All of what you can do in manual mode works with no problems.

I'll start by saying I'm using a Pixel 2 phone. I've tried connecting directly and actually get connected to R2's network via wifi, but the app will not detect R2D2, it just keeps searching?

I've even tried to connect using the local wifi on my 2.4 network and get as far as R2 scanning the code, but nothing ever happens there either? I'm having a hard time getting the blue light to flash rapidly. It's hit and miss if it flashes slow or fast? I was wondering if there could be a camera issue, but I've noticed him turn his front light blue, turn his head and look at me when I'm sitting on the floor by him?

I've gone through trying to get him to connect multiple times both ways, I uninstalled the app and reinstalled the app. The only thing I question are his back lights? Sometimes they will flash yellow/green if he is in patrol mode or just sitting there?

I've read the entire users manual over and over, I've searched here and found people that had the same problem, but no one has answered what the fix is? Any ideas, I'm highly frustrated!

EDIT: I have tried again several times for direct wifi and the app still just searches for R2 even though my phone says it's connected to R2's network. In the local wifi setup I did get R2's blue light to flash rapidly when I hold the image in front of his camera and he appears to scan the image but comes back with a red light and he does not connect? Is there a certain distance the image should be from him?

I'm pretty positive that his camera is working. While sitting in front of him his blue light will come on and his head turns to look at me. He will even follow my face if I move in front of him.
skyfire
#2 Posted : 05 November 2019 05:35:00

Rank: Pro

Build-Diary Medal: Build-Diary Medal of HonourPublisher Medal: Article published Medal
Groups: Registered

Joined: 20/01/2011
Posts: 354
Points: 976
Location: Canberra, Australia
Having a bit of a think about this not connecting issue, have you tried slowly moving the card, (or whatever the code is on) slowly toward R2D2 and seeing if that works and if it doesn't, try slowly moving it away from him.

My thoughts are that R2D2 is maybe trouble focusing on the code. Also what is the room lighting like when youwere trying to get R2D2 to read the code?
Namaste - R.I.P. Eva, CF took you far too early, I will never forget you!!! - "The greatest thing you will ever learn, is just to love and be loved in return -- Moulin Rouge" Love Love Love - R.I.P. Gran, I will love you always. - Life is not measured by the number of breaths we take, but by the moments that take our breath away. - Fear does not stop death. It stops life. - Vivir con miedo es como vivir a medias - A life lived in fear is a life half lived.
Charlie Dude
#3 Posted : 05 November 2019 18:11:27

Rank: Beginner Level 3

Groups: Registered

Joined: 04/09/2019
Posts: 28
Points: 84
Location: Kent, Wa.
skyfire wrote:
Having a bit of a think about this not connecting issue, have you tried slowly moving the card, (or whatever the code is on) slowly toward R2D2 and seeing if that works and if it doesn't, try slowly moving it away from him.

My thoughts are that R2D2 is maybe trouble focusing on the code. Also what is the room lighting like when youwere trying to get R2D2 to read the code?


I've tried holding the code on the phone screen anywhere from 2 inches to a foot away, in different lighting conditions, and different angles. It appears that the sweet spot is about 4 inches from his camera where he will consistently scan it and flash the red light once or twice saying he can't connect? I'm assuming that's what it means?

I even dug out my older Moto X phone with Android 5.1 on it thinking maybe my Pixel 2 with Android 10 on it might be the problem. That wasn't the case, he does the exact same thing as the Pixel 2 when trying to connect direct of local.

I have discovered a few other interesting things. The yellow/green light flashing is supposed to mean he's in Voice Recognition Mode, which he is. I found out when the lights are flashing he responds to voice commands like "raise light saber", "move forward", "lower light saber, and who knows what else he will respond to? He will also just start playing the "Luke Hologram" for no reason. All of this is happening while he is just turned on and not connected to any network?

This really has me puzzled, it's as if he's not transmitting, but yet I'm able to connect to his network, but the app just keeps searching for R2. Except for not being able to connect, everything works. I checked all the plugs making sure they were all connected properly, and fully plugged in. I made sure not to touch the PCB while installing it and only had to touch it to install the camera ribbon cable.

Interesting development: While typing the above response I left my phone on the table next to R2 and he connected directly. I was able to use the app to control him and can verify that indeed the camera is working and not a bad picture either. I disconnected and tried again to connect and the app is now searching again. He connected directly again and I found out that now if you close the app and reopen it he will connect immediately. All this is using my Moto X, I haven't tried my Pixel 2 yet, that's next. I'm going to try the local network and see if that started working?

I'm leaning towards a possible bad PCB from issue 99 as the problem?
admin
#4 Posted : 05 November 2019 19:30:04
Rank: Administration


Groups: Administrator, Administrators

Joined: 24/08/2009
Posts: 994
Points: 3,131
Hi Charlie,

Give CS a call, tell ‘em I sent you. Get a replacement ordered. It will be 3 weeks or so to get the part.
Mark Adams
Charlie Dude
#5 Posted : 05 November 2019 19:59:34

Rank: Beginner Level 3

Groups: Registered

Joined: 04/09/2019
Posts: 28
Points: 84
Location: Kent, Wa.
admin wrote:
Hi Charlie,

Give CS a call, tell ‘em I sent you. Get a replacement ordered. It will be 3 weeks or so to get the part.


Hi there Mark!

I just got through trying the Pixel 2 and had no luck connecting either way with it again. Using the Moto X you could clearly see from his video on my screen he'd be able to read the code for local network but still flashes the red light once or twice. After trying to connect him to my local network he's now being stubborn again and doesn't want to connect direct on the Moto X? Weird?

I'll give CS a call, but I'm still going to keep trying in the meantime.

Thanks, Charlie

EDIT: Just got off the phone with CS, they're sending me issue 99 with the PCB.
skyfire
#6 Posted : 06 November 2019 07:02:06

Rank: Pro

Build-Diary Medal: Build-Diary Medal of HonourPublisher Medal: Article published Medal
Groups: Registered

Joined: 20/01/2011
Posts: 354
Points: 976
Location: Canberra, Australia
Hope this solves the problem, something for me to lookout for when I eventually get to that stage!
Namaste - R.I.P. Eva, CF took you far too early, I will never forget you!!! - "The greatest thing you will ever learn, is just to love and be loved in return -- Moulin Rouge" Love Love Love - R.I.P. Gran, I will love you always. - Life is not measured by the number of breaths we take, but by the moments that take our breath away. - Fear does not stop death. It stops life. - Vivir con miedo es como vivir a medias - A life lived in fear is a life half lived.
Charlie Dude
#7 Posted : 08 November 2019 01:45:05

Rank: Beginner Level 3

Groups: Registered

Joined: 04/09/2019
Posts: 28
Points: 84
Location: Kent, Wa.
Interesting development:

1.Using a Galaxy S7 with Android 8, R2 can connect with both direct and local network wifi, but it keeps losing the signal and reconnecting in local network wifi. R2 did read the code from the Galaxy 7. which made him learn the network. He learned it really quick too!

2.The Motorola Moto X with Android 5.1 will connect occasionally using direct, and since he has already learned the password code, he will connect with the local wifi, but also keeps losing the signal and reconnecting.

3.I cannot get R2 to connect locally or direct using a Pixel 2 with Android 10 even after he has learned the local network wifi connection.

I tried walking away from R2 to see how strong of a signal he has and it drops off to almost nothing at 25-30 feet away. He has a very strong signal if you hold your phone about a foot away from him, but he'll still lose connection. When I was installing the PCB, one of the things I looked at was his antenna connection which appeared to be fully connected.

I'm thinking there are issues with the app that also need to be addressed. Android 10 was just released about 6 weeks ago or so and I'm wondering if that could also be an issue.

Either way, I'm hoping that a new PCB will correct the issue of connecting and him losing connection?
Charlie Dude
#8 Posted : 26 November 2019 02:07:31

Rank: Beginner Level 3

Groups: Registered

Joined: 04/09/2019
Posts: 28
Points: 84
Location: Kent, Wa.
The replacement PCB showed up today, 20 days isn't bad!

Now to install it and see if that's what the problem is. Only bad thing is I'm getting ready to go on vacation. So, it looks like I won't find out for a couple of weeks, bummer?

Keeping my fingers crossed!
skyfire
#9 Posted : 26 November 2019 10:20:08

Rank: Pro

Build-Diary Medal: Build-Diary Medal of HonourPublisher Medal: Article published Medal
Groups: Registered

Joined: 20/01/2011
Posts: 354
Points: 976
Location: Canberra, Australia
Hope it works out too. Have a great holiday and come back to it all refreshed. :)
Namaste - R.I.P. Eva, CF took you far too early, I will never forget you!!! - "The greatest thing you will ever learn, is just to love and be loved in return -- Moulin Rouge" Love Love Love - R.I.P. Gran, I will love you always. - Life is not measured by the number of breaths we take, but by the moments that take our breath away. - Fear does not stop death. It stops life. - Vivir con miedo es como vivir a medias - A life lived in fear is a life half lived.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2009, Yet Another Forum.NET
This page was generated in 0.114 seconds.
DeAgostini