Welcome Guest Search | Active Topics | Log In | Register

Customer service response time Samba pack 9 & 10 Options
undoo
#1 Posted : 03 December 2020 18:44:22

Rank: Newbie

Groups: Registered

Joined: 18/11/2020
Posts: 2
Points: 9
Location: UK
Hi,
everything was working fine with my build up until assembling package 9 when parts 85-1 and 86-1 failed. I have then contacted customer service via the same email address as I used to order the kit and some guy named Tom replied on 18th of November that the parts will be replaced but I should allow 10 days for delivery. Wow, great, what a nice customer service - silly me has thought.

Few days have gone and a new delivery arrives - what a fine surprise, let's check it out - might be the next delivery - the 10th - and if I am lucky enough - the replacement broken parts as well.

It seems that I was wrong on both assumptions as I was kindly provided with a second delivery of the 9th package. I then replied to the email I had from Tom explaining that instead of the correct package I got a duplicate of the 9th and I got a reply the second day (1st of Dec) from a guy named Martin asking for the order number - although I think this could have been obtained by looking for the email address, otherwise I don't know how the first guy would have handled my request other than simply ignoring it and giving me a sorry to hear this and some false promises in return.

I sent my reply within a few minutes after getting his email providing him with the order number and told the story again from the beginning. What should be the waiting time to get a response on these issues since two and a half days have already past and there was no news whatsoever?

Cheers.

delboy271155
#2 Posted : 03 December 2020 20:14:48

Rank: Super-Elite

Publisher Medal: Featured Build of the MonthActive Service Medal: 500 post active service MedalPurple Medal: Super active service medal for 1000 postsRed Medal: Red MedalTurquoise Medal: Turquoise Medal for model making know-how contributionBuild-Diary Medal: Build-Diary Medal of Honour
Groups: Registered, Administrators, Global Forum Support Team, Moderator, Official Builds

Joined: 09/11/2012
Posts: 7,076
Points: 20,784
Location: East midlands
undoo wrote:
Hi,
everything was working fine with my build up until assembling package 9 when parts 85-1 and 86-1 failed. I have then contacted customer service via the same email address as I used to order the kit and some guy named Tom replied on 18th of November that the parts will be replaced but I should allow 10 days for delivery. Wow, great, what a nice customer service - silly me has thought.

Few days have gone and a new delivery arrives - what a fine surprise, let's check it out - might be the next delivery - the 10th - and if I am lucky enough - the replacement broken parts as well.

It seems that I was wrong on both assumptions as I was kindly provided with a second delivery of the 9th package. I then replied to the email I had from Tom explaining that instead of the correct package I got a duplicate of the 9th and I got a reply the second day (1st of Dec) from a guy named Martin asking for the order number - although I think this could have been obtained by looking for the email address, otherwise I don't know how the first guy would have handled my request other than simply ignoring it and giving me a sorry to hear this and some false promises in return.

I sent my reply within a few minutes after getting his email providing him with the order number and told the story again from the beginning. What should be the waiting time to get a response on these issues since two and a half days have already past and there was no news whatsoever?

Cheers.



Hi Undoo

It appears to me that CS and yourself are at cross purposes.

You need to tell CS that you need replacements for Stage 85 and Stage 86 of the Samba.

To get the best response ring CS on 0333 300 1516 with your account number too hand and quote what I have stated above. When you speak to CS take a note of Date, time and the person you speak too.

Now a question:

You say that the parts mentioned "Failed". Could you please explain what you mean by that and I`ll try to help with the replacement parts when you receive them.


Regards
delboy271155
(Derek)

COME BACK GUY FAWKES "YOUR COUNTRY NEEDS YOU"






undoo
#3 Posted : 03 December 2020 20:49:23

Rank: Newbie

Groups: Registered

Joined: 18/11/2020
Posts: 2
Points: 9
Location: UK
Hi Derek,
thanks for your reply. The thinner part of them broke up when I was trying to align them with 82-1 after fitting it with the screws.
File Attachment(s):
IMG_20201118_220433 (1).jpg (1,440kb) downloaded 13 time(s).
IMG_20201118_220441 (1).jpg (1,583kb) downloaded 8 time(s).
IMG_20201118_220458 (1).jpg (1,311kb) downloaded 10 time(s).
Pirate
#4 Posted : 03 December 2020 22:01:43

Rank: Newbie

Groups: registriert

Joined: 02/09/2020
Posts: 1
Points: 3
undoo wrote:
Hi,
everything was working fine with my build up until assembling package 9 when parts 85-1 and 86-1 failed. I have then contacted customer service via the same email address as I used to order the kit and some guy named Tom replied on 18th of November that the parts will be replaced but I should allow 10 days for delivery. Wow, great, what a nice customer service - silly me has thought.

Few days have gone and a new delivery arrives - what a fine surprise, let's check it out - might be the next delivery - the 10th - and if I am lucky enough - the replacement broken parts as well.

It seems that I was wrong on both assumptions as I was kindly provided with a second delivery of the 9th package. I then replied to the email I had from Tom explaining that instead of the correct package I got a duplicate of the 9th and I got a reply the second day (1st of Dec) from a guy named Martin asking for the order number - although I think this could have been obtained by looking for the email address, otherwise I don't know how the first guy would have handled my request other than simply ignoring it and giving me a sorry to hear this and some false promises in return.

I sent my reply within a few minutes after getting his email providing him with the order number and told the story again from the beginning. What should be the waiting time to get a response on these issues since two and a half days have already past and there was no news whatsoever?

Cheers.



You wrote CS to replace parts fron pack 9. Then you recieved a replacement pack 9 ( they don‘t replace parts but whole packs). What excactly is your issue?
delboy271155
#5 Posted : 03 December 2020 22:04:10

Rank: Super-Elite

Publisher Medal: Featured Build of the MonthActive Service Medal: 500 post active service MedalPurple Medal: Super active service medal for 1000 postsRed Medal: Red MedalTurquoise Medal: Turquoise Medal for model making know-how contributionBuild-Diary Medal: Build-Diary Medal of Honour
Groups: Registered, Administrators, Global Forum Support Team, Moderator, Official Builds

Joined: 09/11/2012
Posts: 7,076
Points: 20,784
Location: East midlands
Hi Again,

I`ve looked at your pics having downloaded them (We can deal with posting pics at a later date Blink ) and I`ve copied and highlighted some issues which may have caused your problem.

In the picture below (you may need to refresh the page a couple of times to get it to show) you will notice two circles. These concern me as this is damage caused between the parts.

You will also notice two thin white lines. these show the hinge is not aligned correctly.

The white arrow points at a screw that does not look fully inserted.

So not knowing exactly when the parts failed, I`ll start with the two white circles and thin white lines:

The larger circle shows scraping to the hinge plate that I would not expect as the hinge is fitted after the broken part. The smaller circle shows where the locating pin has come out of the hole.

The thin white lines show the misalignment of the hinge to the part they are attached too.

So, a question: Did you accidentally fit the hinge first?, because if you did the hinge has got under the panel and as you have fixed the two screws in place it would put pressure on the diecast panel and it will fracture. We all make mistakes at some time. Not a problem BigGrin .

The arrow points to a screw that doesn`t look fully inserted.

When using self tapping screws the best method is to screw the screw in 1-2 turns and then back the screw off half a turn. Screw it in another full turn and back off half a turn again. By backing off the screw half a turn as instructed the swarf (cut metal) is removed so the screw does not lock tight before its fully inserted.

Now what to do?

As mentioned earlier contact CS and ask for replacements for stage 85 and 86.

When the parts arrive, start rebuilding. These kits should just slot together, so at the first sign of resistance stop and post the issue, or PM me to let me know you`ve hit a snag.


Regards
delboy271155
(Derek)

delboy271155 attached the following image(s):
IMG_20201118_220441 (1).jpg
COME BACK GUY FAWKES "YOUR COUNTRY NEEDS YOU"






delboy271155
#6 Posted : 03 December 2020 22:36:56

Rank: Super-Elite

Publisher Medal: Featured Build of the MonthActive Service Medal: 500 post active service MedalPurple Medal: Super active service medal for 1000 postsRed Medal: Red MedalTurquoise Medal: Turquoise Medal for model making know-how contributionBuild-Diary Medal: Build-Diary Medal of Honour
Groups: Registered, Administrators, Global Forum Support Team, Moderator, Official Builds

Joined: 09/11/2012
Posts: 7,076
Points: 20,784
Location: East midlands
Pirate wrote:
undoo wrote:
Hi,
everything was working fine with my build up until assembling package 9 when parts 85-1 and 86-1 failed. I have then contacted customer service via the same email address as I used to order the kit and some guy named Tom replied on 18th of November that the parts will be replaced but I should allow 10 days for delivery. Wow, great, what a nice customer service - silly me has thought.

Few days have gone and a new delivery arrives - what a fine surprise, let's check it out - might be the next delivery - the 10th - and if I am lucky enough - the replacement broken parts as well.

It seems that I was wrong on both assumptions as I was kindly provided with a second delivery of the 9th package. I then replied to the email I had from Tom explaining that instead of the correct package I got a duplicate of the 9th and I got a reply the second day (1st of Dec) from a guy named Martin asking for the order number - although I think this could have been obtained by looking for the email address, otherwise I don't know how the first guy would have handled my request other than simply ignoring it and giving me a sorry to hear this and some false promises in return.

I sent my reply within a few minutes after getting his email providing him with the order number and told the story again from the beginning. What should be the waiting time to get a response on these issues since two and a half days have already past and there was no news whatsoever?

Cheers.



You wrote CS to replace parts fron pack 9. Then you recieved a replacement pack 9 ( they don‘t replace parts but whole packs). What excactly is your issue?


His issue is being dealt with Thankyou.

Regards
delboy271155
(Derek)

COME BACK GUY FAWKES "YOUR COUNTRY NEEDS YOU"






roymattblack
#7 Posted : 04 December 2020 00:06:27

Rank: Super-Elite

Publisher Medal: Featured Build of the MonthActive Service Medal: 500 post active service MedalPurple Medal: Super active service medal for 1000 postsRed Medal: Red MedalOutstanding Build: An award for an outstanding buildBuild-Diary Medal: Build-Diary Medal of Honour
Groups: Registered, Moderator, Administrators, Global Forum Support

Joined: 04/06/2011
Posts: 3,319
Points: 10,100
Location: ipswich
C/S are usually really good if they have detailed info about the problem, and exactly what parts are at fault.
Maybe just not good communication this time?

Anyway - when the new parts arrive, I would go back and 'start again' with this section.
As has been suggested, it appears that there might be a few build errors.
Nothing major - but these things often have a knock-on effect.

I'm sure you'll get it sorted.BigGrin
CaptnBirdseye
#8 Posted : 04 December 2020 18:34:07

Rank: Elite

Active Service Medal: 500 post active service MedalPurple Medal: Super active service medal for 1000 postsRed Medal: Red MedalBuild-Diary Medal: Build-Diary Medal of Honour
Groups: Registered, Official Builds

Joined: 10/05/2010
Posts: 2,460
Points: 7,069
Location: Lincolnshire
Unsure Well I’ve tried 5 times to ring CS and it each time it went to holding music......for about 11 minutes then goes completely quiet so you don’t know if you’ve been cut off or not Cursing
After 25 minutes of silence I hung up ThumbDown

Not sure if they’re back from furlough or not!
admin
#9 Posted : 05 December 2020 07:57:57
Rank: Administration


Groups: Administrator, Administrators

Joined: 24/08/2009
Posts: 1,531
Points: 4,680
Location: Nevada, US
Guys, if you could shoot me a PM about your issues...

Stay well!

Mark
Mark Adams
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2009, Yet Another Forum.NET
This page was generated in 0.184 seconds.
DeAgostini