Welcome Guest Search | Active Topics | Log In | Register

Electronics Dead Options
jgmayer
#1 Posted : 08 January 2021 04:08:30

Rank: Beginner Level 1

Groups: Registered

Joined: 31/03/2018
Posts: 5
Points: 15
Location: Marshfield, WI
Just completed issue 87 and when I tried the electronics nothing works. Everything was working at prior testing stages, but now its all dead. Have tried two sets of batteries. I've had horrible luck with these kits, I've never gotten the R2D2 to even turn on (again worked at all testing parts), and now this one where everything was fine until the final assembly. Really don't want to have to tear this apart, did that twice with the R2D2, which was a waste of time. Any guesses as to what is wrong?

Thanks.
Markwarren
#2 Posted : 08 January 2021 10:07:19

Rank: Super-Elite

Publisher Medal: Featured Build of the MonthActive Service Medal: 500 post active service MedalPurple Medal: Super active service medal for 1000 postsRed Medal: Red MedalTurquoise Medal: Turquoise Medal for model making know-how contributionOutstanding Build: An award for an outstanding buildBuild-Diary Medal: Build-Diary Medal of Honour
Groups: Administrators, Global Forum Support, Registered, Moderator, Official Builds

Joined: 04/01/2016
Posts: 5,766
Points: 17,579
Location: Northamptonshire, England
Assuming you did the test stage at 74, I can only say to check the cables on the board in case one has been dislodged.

Mark
clay
#3 Posted : 08 January 2021 15:26:54

Rank: Amateur level 2
Build-Diary Medal: Build-Diary Medal of Honour
Groups: Registered

Joined: 10/09/2018
Posts: 41
Points: 126
Location: Texas
I ran into several issues with my install! Check the power switch! Mine was not soldered on - the heat shrink was the only thing making the wires make contact. I soldered it myself. I also had the wires break for the motors - both of them! Not the manufacturers fault, twas mine (except the switch wires!) Also, you need to ensure you are using the remote right next to the antenna! Nothing will work if you aren't close to the antenna!!!

Just my .02...

Clay
S4Simon
#4 Posted : 09 January 2021 00:10:55

Rank: Pro
Publisher Medal: Featured Build of the MonthRed Medal: Red MedalBuild-Diary Medal: Build-Diary Medal of Honour
Groups: Registered

Joined: 28/01/2016
Posts: 126
Points: 368
Location: Adelaide, Australia
I’ve built a few of these complex builds now and have found the CPU’s in all the builds to be pretty much bullet proof. The major weak point of the builds are when a builder disconnects wiring. Every time this is done the connection point weakens to a point of failure. General rule is - don’t pull the wires, only the connector. Other issues are misaligned or inverted connectors.

If all was working in the pre test, then it’s either a connector issue or damaged wire.

I’d say that from all the problems I’ve seen on Facebook pages and here on this forum, 95% of the problems are finger related. These are complex systems and require patience and a high level of hand skills. As an ex military guidance system engineer, it’s a matter of check, check, install and check again.
BUILDING: Hachette Bismarck, Hachette Spitfire

COMPLETED: Deagostini Millennium Falcon, Deagostini R2-D2
admin
#5 Posted : 09 January 2021 08:02:36
Rank: Administration


Groups: Administrator, Administrators

Joined: 24/08/2009
Posts: 1,625
Points: 5,045
Location: Nevada, US
What I’ve taken to doing is using a Bondic UV cure pen to bond the connectors to the board better. It’s non-conducive, so is the perfect solution to the connectors pulling off. As far as the wire side, I remove the lock on the connector. It’s not going to be placed under load when the build is finished, so that alleviates the need to lock the connectors together.

Hth!

Mark
"Each person you interact with, is an entire universe unto themselves .."

Albert Eisenstein

.

clay
#6 Posted : 11 January 2021 14:53:58

Rank: Amateur level 2
Build-Diary Medal: Build-Diary Medal of Honour
Groups: Registered

Joined: 10/09/2018
Posts: 41
Points: 126
Location: Texas
Now you tell me Mark!!!Cursing

Just kidding...that's a damn fine idea!

Clay
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2009, Yet Another Forum.NET
This page was generated in 0.164 seconds.
DeAgostini